要超过java1.8了??php7.4要求非常高,性能接近swoole???插图

前两天用阿里30¥云小鸡安装的lnmp。

然后直接失败了

php 安装失败了我用的是centos6.9

军哥说是

PHP 7.4升级或安装必须CentOS 8+,Debian 8+,Ubuntu 16.04+且必须使用1.7!!!

然后搜了下

https://**blogs.com/chenpingzhao/p/10605712.html

说接近swoole?加载到内存里面了?

对了 这下面这是什么神仙 三元操作?看不懂 来个大佬解释下

$data['date'] = $data['date'] ?? new DateTime();

PHP 7.4 之后你可以这样:

$data['date'] ??= new DateTime();

找到了

// 获取 $_GET['user'] 的值,如果它不存在则返回 nobody

$username = $_GET['user'] ?? 'nobody';

// 这等价于:

$username = isset($_GET['user']) ? $_GET['user'] : 'nobody';

9 对 “php7.4要求非常高,性能接近swoole???”的想法;

  1. 晴晴晴 发表于 2020-3-27 19:09
    PHP10.0

    $a = x0XX .?1242 R3Q414 `

    什么玩意,跟鸡挠的一样,  看不懂,一点都不符合命名规范,

    php要是写成这样,我直接放弃这语言

  2. Nameless 发表于 2020-3-27 19:04
    centos 6.9 你要光复大清?

    小鸡呀!跑那么高版本的 不合适吧,

    太臃肿了吧  能“接打电话”就行了,不要太多功能

  3. 胖虎 发表于 2020-3-27 19:40
    相当于默认开opcache?

    我也不知道,要是这样,还用啥缓存 redis啥的,直接上7.4 不爽歪歪

    又是一个重大的革新。   

评论被关闭。